Topics aren’t launching automatically - autolauncher troubleshooting

After setting up autolaunchers, topics should launch automatically for users upon logging-in based on the chosen rules. However, if you still can’t get a topic to launch automatically, you can troubleshoot to find out what is wrong. In this article, we will show you what you need to check and how to do it.

Check the status

The first thing to do when the autolauncher is not working is to check the status.

  1. Go to the page where the topic should launch automatically, open the Authoring tool and click the Status button. If you initially get a result that Player is not installed, reload the page while the Authoring tool is open.

  1. The status tool will check if the autolauncher is active on this page based on the segments and activation rules that have been set. To see detailed results, click the autolauncher title. You will see set rules of the autolauncher and also rules of the segment.

How to read the results?

autolauncher...starts - it’s the number of times the autolauncher has been played for the user. It reflects the "number of plays" option set in the autolaunchers settings. To access autolauncher settings navigate to Sites within Inline Manual portal -> choose a site -> navigate to Automation tab -> choose the desired autolauncher and click the edit button.

In the screenshot, you can see it’s set to less than 1 but it has an X because the current value is 1. It means that the autolauncher has already been seen once. The rule does not match.

autolaunchers...completions - it’s the number of times the topic has been completed.

If you have chosen for the autolauncher to Play only if a topic wasn’t completed, you will get an X when the topic has already been completed by the user.


You will get a green check mark if the user hasn’t completed the topic yet.

New users and created within 30 minutes - this is the segment that the topic is available to.

created within 30 minutes - this is the rule of the segment we used in this example. Other rules of the specified segment will come up here so you can see if they match or not for the current user.

In the screenshot above, you will see that the autolauncher is only available to the “Segment” New Users.

Every rule you see in this section reflects the rules set in the autolauncher settings in the Inline Manual portal as well as the rules of the specific segment.

  1. If you set up URL match in the autolauncher settings, you will also see it in the autolauncher details in the status tool. It will display the pattern you used and the URL it’s detecting so you can compare it. Check the URL you added in Advanced activation rules of the autolauncher. If the URL matches, you will get a green check mark.


  1. Check Segments tab to see if segments you created are working on your website. A green check will show if rules are met, and an X mark if they aren’t. You can see details of each segment by clicking on the desired segment.

To check what rules are set up for the segment, go to Inline Manual portal -> then go to Sites and choose a correct site -> navigate to Segments tab -> click Edit segment next to the segment you want to check. Compare it with the results of the Diagnostics tool. Remember that if users don’t belong to the assigned segment, the topic won’t launch for them.

To check whether the topic is available to the segment, go to Sites and choose a correct site -> check Available to: under the topic title. Available to feature means that the topic will be visible only to assigned segments.

Enable the Player Debug Widget.

With the debug widget you can check the most recent time the player has been updated in the application. It may take a few minutes to populate changes on your site. For instruction on how to enable the debug player, go here.

Checking the above elements, such as segments, assigned URL and the time of the last player update, will help you determine why the autolauncher is not working. If you still can’t figure out why your autolaunchers are not working, contact our Support team at support@inlinemanual.com. Don’t forget to include the screenshot of the status results!

Related articles

How to: the Player Debug Widget
Inline Manual Diagnostic Tool - Status

autolauncher
troubleshooting
FAQ
Was this article helpful?